Incident
On Sunday, Mar 01, 2020 at around 08:30am CT, Scanova's production server went offline. The outage continued till 11:00pm CT, before it was made live again by Scanova's engineering team.
During this outage period, Scanova's customers and end-users (people who scan QR Codes) were:
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Able to access Scanova's website (https://scanova.io)
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Not able to access Scanova's app (https://app.scanova.io)
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Not able to access Scanova's API
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Not able to access content linked with Dynamic QR Codes
Please be assured that this is a one-off incident and the previous non-maintenance outage occurred only in Aug 2019.
Cause
The outage was a result of a data security preventive measure taken by our primary cloud server service provider Amazon Web Services (AWS).
The preventive measure was taken to block a malicious user's attempt to abuse Scanova's platform to host a phishing attack targeting Amazon users.
In general, it is common for software service providers that provide redirection service (such as bit.ly, goo.gl, or Scanova via Dynamic QR Codes) to become a target of abuse by malicious users attempting phishing attacks. See: List of Top Abused Redirectors.
Statement on Prevention of Such Incidents
To stop the menace of phishing attempts, Scanova employs a robust security process that employs trusted security tools (such as Google Safebrowsing) and internal screenings. The system screens the URL linked to each Dynamic QR Code (both programmatically and manually) to ensure only genuine URLs are linked. Using this system, we are able to successfully block 30-50 phishing attempts per week.
However, as attackers continuously employ new methods to mask their attack, one attack was able to bypass the system, prompting AWS to shut down the server temporarily.
As a result of this incident, Scanova has identified opportunities to strengthen its security and URL screening processes, which are already in implementation.
Scanova is also taking the assistance of AWS and Netcraft security teams to prevent future incidents.
While we understand that online software systems cannot be perfect, we strive to ensure that such incidents are negligible. We will be taking this incident as an opportunity to further strengthen the efficiency of our system’s infrastructure and security processes.
If you or your end customers were unable to use our QR Codes during this period due to the incident, we apologize.
If you have any questions or concerns, feel free to reach out to us at support@scanova.io.