Este informe proporciona detalles de la interrupción experimentada por los clientes del Generador de Códigos QR de Scanova el 1 de marzo de 2020.
Incidente
El domingo, 1 de marzo de 2020, alrededor de las 08:30 am CT, el servidor de producción de Scanova se desconectó. La interrupción continuó hasta las 11:00 pm CT, antes de que fuera restablecido por el equipo de ingeniería de Scanova.
Durante este período de interrupción, los clientes y usuarios finales de Scanova (personas que escanean los códigos QR) experimentaron lo siguiente:
- Pudieron acceder al sitio web de Scanova (https://scanova.io/)
- No pudieron acceder a la aplicación de Scanova (https://app.scanova.io/es)
- No pudieron acceder a la API de Scanova
- No pudieron acceder al contenido vinculado con los códigos QR dinámicos
Ten la seguridad de que este incidente fue un caso aislado y la última interrupción no relacionada con el mantenimiento ocurrió solo en Agosto de 2019.
Causa
La interrupción fue el resultado de una medida preventiva de seguridad de datos tomada por nuestro proveedor de servicios de nube principal, Amazon Web Services (AWS).
La medida preventiva se tomó para bloquear el intento de un usuario malicioso de abusar de la plataforma de Scanova para alojar un ataque de phishing dirigido a usuarios de Amazon.
En general, es común que los proveedores de servicios de software que ofrecen servicios de redirección (como bit.ly, goo.gl o Scanova a través de códigos QR dinámicos) se conviertan en objetivos de abuso por parte de usuarios malintencionados que intentan realizar ataques de phishing. Consulta: Lista de los principales redireccionadores abusados.
Declaración sobre la prevención de este tipo de incidentes
Para detener el problema de los intentos de phishing, Scanova emplea un sólido proceso de seguridad que utiliza herramientas de seguridad confiables (como Google Safebrowsing) y revisiones internas. El sistema examina la URL vinculada a cada código QR dinámico (tanto de forma programada como manual) para asegurarse de que solo se vinculen URL genuinas. Utilizando este sistema, hemos logrado bloquear con éxito de 30 a 50 intentos de phishing por semana.
Sin embargo, dado que los atacantes emplean continuamente nuevos métodos para enmascarar sus ataques, un ataque logró eludir el sistema, lo que llevó a que AWS cerrara temporalmente el servidor.
Como resultado de este incidente, Scanova ha identificado oportunidades para fortalecer sus procesos de seguridad y revisión de URL, los cuales ya están en implementación.
Scanova también está contando con la ayuda de los equipos de seguridad de AWS y Netcraft para prevenir futuros incidentes.
Si tú o tus usuarios finales no pudieron utilizar nuestros códigos QR durante este período debido al incidente, nos disculpamos.
Si tienes alguna pregunta o inquietud, no dudes en contactarnos en support@scanova.io.